Results 1 to 2 of 2

Thread: Anyone ever seen this before?

  1. #1

    Default Anyone ever seen this before?

    The truck as been sat on the drive for 2 weeks. Yesterday I noticed a pool of fresh transmission fluid under the truck. Couldnít see exactly where it was coming from. Pulled the dip stick and the tube was full of fluid and it seems to have overflowed from there. Started it up and the level went down. Iíve had the truck over a year and never touched the transmission. Record show it was serviced before I bought it and was returned due to a leak. The conclusion was it had been over serviced.
    My first thought was maybe water had got in there and was pushing the fluid out but weíve had no rain for a couple of weeks.

    Anyone ever seen this before?

  2. #2
    Join Date
    May 2006
    Posts
    2,005

    Default

    A similar occurence happened to my 92 Classic Range Rover.
    I have had no leaks before on the vehicle or since.
    Topped it up after the "surge" of fluid and all has been well since.

    Anyone else have an issue like this?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us