Results 1 to 3 of 3

Thread: Transmission help

  1. #1

    Default Transmission help

    Took my 98 Disco 1 to the gas station and filled up the other day. Pulled out and speed up to about 50. Then the trans felt like it went into neutral and I had to coast into a parking lot. Then none of the gears would do anything. Like it's in neutral all the time. There are no abnormal noises. I put it into diff lock and low range no change. If I start it up cold it works for about 30 seconds forward and reverse. Then nothing.

    I was was wondering if anyone had any experience with this symptom. Maybe trans pump or torque converter?

  2. #2
    Join Date
    May 2006
    Posts
    2,190

    Default

    What colour is the transfluid?
    Is it to the correct level?
    I would try changing the trans oil and filter and see how it performs.


    2p
    Les Parker
    Tech. Support and Parts Specialist
    Rovers North Inc.

  3. #3
    Join Date
    Oct 2011
    Location
    Mountains of Western Pennsy.
    Posts
    489

    Default

    Sounds like the front trans pump, ZF's are famous for their pump failures. Try to set the proper level with the proper fluid and change out the filter by all means, you might get lucky. And be sure to follow the RAVE or other shop manual for refilling, you don't just dump in two gallons of fluid, there is a procedure for this.

    '99 Disco II
    '95 R.R.c. Lwb (Gone...)
    '76 Series III Hybrid 109
    '70 Rover 3500S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us