Results 1 to 2 of 2

Thread: 99 Disc I SD - not starting

  1. #1

    Default 99 Disc I SD - not starting

    Hello all:

    I am new to this forum. I have a 99 D1, which I have had since new. The other day, it decided not to start at the store. It cranks fine, starter and battery are both about one year old, and very good.

    I have been testing all kinds of things, but basically, it has no fuel at the test port. Fuses are good, but I don't seem to be getting any power at the pump. I have some info I need to double check some things there:
    There are two plugs on the pump: One had three wires, one has four. The four wire plug has two black wires (one is heavier than the other), a green and a white/purple one.
    Can anyone tell me which ones should light up a circuit tester when I cycle the key to the ON position?

    I am always in the position of doubting my tools as well as testing the vehicle.

    This thing ran great until about a week ago, when it threw some codes relating to a misfire in cyl2. I cleared them using a laptop based OBDII system from Ross Tech, which was originally used for VAG COM (VW). It has an OBDII only choice. Once I cleared the codes, everything was fine for a few days. Then this issue. Now, no OBDII reader seems to be able to link properly.

    Other things:
    When I turn the key to the on position, I have two relays which click rapid fire, and don't stop: One is behind the glove box. It is yellow, and is next to a green one, and the other is the evap canister purge valve.

    After this happened, I also changed my plugs and wires, which I had been planning to do anyway. I also don't seem to be getting spark. I am using the #2 cyl plug to test that.

    That is all I know for now. Anyone have any ideas? This is my daily driver, and right now I am being held hostage by it.

    Thanks in advance!

    Bill Brock

  2. #2
    Join Date
    Oct 2011
    Location
    Mountains of Western Pennsy.
    Posts
    488

    Default

    It sounds like the "Immobilizer", part of the security system. These are famous for tripping for no reason and preventing fuel flow (so it can't be stolen and driven away). There is a gadget called a "Spider" that is used to by-pass this problem, info on this is on line. Get yourself a free download of the "RAVE" Land Rover manual, it will be invaluable for electrical and mechanical repairs. I've seen people go around and open and close all the doors and lock and unlock the system and the car magically starts. I use a dedicated Land Rover scanner by Bear Mach to do any trouble shooting, it's not cheap but, it pays for itself in only a couple uses, considering dealer's shop costs. For better information than mine, go over to "Discoweb", there are more active folks over there that can help out.

    '99 Disco II
    '95 R.R.C. Lwb (Gone...)
    '76 Series III Hybrid 109
    '70 Rover 3500S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us