Results 1 to 8 of 8

Thread: 1974 Series III brake light switch.

  1. #1

    Default 1974 Series III brake light switch.

    Obvious new guy here but series Rover number six.......

    I am having a stretch of bad luck with brake light switches. I have replaced two in less than a month and now this one is not working. Did all the wire to wire and everything is working fine with brake lights working. Have had it out several times and tried it that way and not working. Am i having a stretch of just bad switches or do you have any other thoughts? Getting them from host and works good for about a week and then nothing. Thanks for any ideas.

  2. #2
    Join Date
    Oct 2006
    Posts
    1,189

    Default

    Your experience is not unusual.

  3. #3
    Join Date
    Oct 2014
    Location
    North Carolina
    Posts
    30

    Default

    How about a genuine one on eBay?
    1976 RHD Series 3
    1940 Piper J3F-50 Cub

  4. #4

    Default

    Quote Originally Posted by fly cubs View Post
    How about a genuine one on eBay?
    That's what i did just now. Sent the two bad ones back and got a genuine one. Hope it will last a long time.

  5. #5

    Default

    Follow up on this switch. Made a call to our host explaining the switch problems, sent the old ones back and in a flash had a original Land Rover part in hand. Thats what i call good service.

  6. #6
    Join Date
    Oct 2014
    Location
    North Carolina
    Posts
    30

    Default

    Quote Originally Posted by 01birddog View Post
    Follow up on this switch. Made a call to our host explaining the switch problems, sent the old ones back and in a flash had a original Land Rover part in hand. Thats what i call good service.
    That's awesome. Definitely one of the reasons I always come back to them!
    1976 RHD Series 3
    1940 Piper J3F-50 Cub

  7. #7

    Default

    Yes good folks.........I had about 500 hrs in old NC6914H. Dont know what happened to her. Beautiful Cub i restored years ago.

  8. #8
    Join Date
    Apr 2010
    Location
    NE Florida
    Posts
    28

    Default

    I have had your exact experience with multiple brake light switches, both Genuine and aftermarket. Issue I've noticed is with the "plunger"; nothing wrong electrically. If I remove the switch, exercise the plunger and test, it starts working fine. But replace it in the brake tower, adjust it properly and it regularly stops working again in a matter of just a few trips. Frustrating. Is this similar to anybody else's findings?
    1973 Series III 88"
    Pretty good performance from the old 2.25 petrol! Then again, she does have the Fairey overdrive...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us