Results 1 to 2 of 2

Thread: 200Tdi alternator light on alternator charging

  1. #1

    Default 200Tdi alternator light on alternator charging

    Hi
    I have a 1985 110 with a 200Tdi. currently the alternator light is on but if I measure voltage across the battery, I get about 13.7. Without the engine running the voltage is about 12.7. I wouldn't be too concerned but I have noticed that as the rpm increases the voltage across the battery increases also and I have measured it as much as 18 volts. Obviously there's a problem but I'm wondering 1) can I continue to drive it until I fix it?; 2) would there be any possibility that this is an external loose connection or short?
    Any help will be greatly appreciated.
    Thanks
    Bill

  2. #2
    Join Date
    Oct 2011
    Location
    Mountains of Western Pennsy.
    Posts
    513

    Default

    It sounds like an internal problem. And since most everything in the electrical system is made to use no more than about 15v, it could be damaging the battery and other components.

    '99 Disco II
    '95 R.R.C. Lwb (Gone...)
    '76 Series III Hybrid 109
    '70 Rover 3500S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us