Results 1 to 2 of 2

Thread: Vapor Lock 64 2A

  1. #1
    Join Date
    May 2015
    Location
    Redding, CT
    Posts
    12

    Default Vapor Lock 64 2A

    Hi everyone, This is my 4th summer as a Rover owner and I've had some issues with vapor lock before but this seems different. In the past I put some reflective insulation on my fuel line and all was fixed, no more stalling or hard starting. But the hard starting is back, after I shut the truck off for 5 mins or more on a warm day it takes a good 7-10 seconds of cranking to start the engine. I assumed all the gas was boiling out of the carb and the cranking was filling a dry carb but the engine actually behaves like it's flooded. It won't start unless I hold the throttle wide open and then it spits out a ton of dark, rich exhaust when it turns over. I looked down into the intake and can see there is gas coming from the accelerator pump when I open the throttle manually so that tells me there is gas in the bowl. My theory is that the heat causes the gas to boil, building pressure and forcing the liquid into the the intake ( I can see the gas dripping) this floods engine and once the bowl is empty, fresh gas from the line fills it up and the process continues until the carb cools enough. There are also gas stains all over the intake manifold, which has never happened before this summer. See Pics


    I rebuild the carb and re-routed the fuel line to run along the bulkhead instead of directly over the engine. This seems to have helped a little bit but I'm still having a problem. I've been told to install an electric fuel pump but this isn't going to solve the problem, it's just going to mask it. I also thought of buying an in-line fuel filter with a vapor return and running a line back to the tank but I don't think this will help much as I believe the problem is the hot carb.

    Has anyone out there fabricated a heat shield to sit just below the carb? Does anyone else have a similar problem or any ideas??

    Thanks!Name:  IMG_2312.jpg
Views: 26
Size:  89.9 KB

  2. #2
    Join Date
    Feb 2014
    Location
    Dallas, TX
    Posts
    70

    Default

    Living in Texas, I've had a fair amount of VL issues. Runs fine in the heat, but then I park and the heat soak happens while I'm in the store or whatever. I come back out and it'll start (fuel in the carb) but I'll make it about 400ft and it dies.

    My solution was to get a thermal sleeve for the fuel line. This is what I bought (thermal sleeve)

    So far so good. For the price it's worth a try.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us