Results 1 to 3 of 3

Thread: Disco II cylinder 1 and 6 misfire issue

  1. #1
    Join Date
    Jun 2007
    Posts
    17

    Default Disco II cylinder 1 and 6 misfire issue

    Hey folks. Hoping for some light in the recent darkness that has been Disco II ownership.

    Not my first rodeo with Rovers. Been in the game for about 30 years. However, my current '04 Disco II is wearing thin.

    About two months ago, I started sensing I had a misfire. It began about the time I was rear ended on my way to work.

    I checked the coil packs and they were not fully secured. Thinking that maybe they took a hit, I purchased new coil packs and relocated them out front. New 8mm wires.

    Issue seemed to go away. For awhile. Then it returned on my honeymoon in Canada. We limped to a friends place and we ended up doing the head gaskets there. Also replaced the front O2 sensors and plugs.

    Seemed good for awhile, and then on the highway on the way home, we could sense a miss or perhaps a slip. Hard to tell which. No codes.

    Got home and it was rough. Definitely missing. Codes were for cylinder 1 and 6 misfire. Sure enough, not great spark on those plugs. Replaced the plugs with more 8mm plugs. Tested with a spare coil and the new coil was found to be good.

    Thought that a wire on the coil plug might be suspect, so replaced the plug with a new unit.

    Truck was perfect for a couple of weeks. Then, Cylinder 1 and 6 misfires back. Felt an occasional miss/slip the few days preceding the misfires today. Misfires bad enough today that I've parked the truck.

    So, I'm down to two(or three) possible issues and welcome suggestions and shared wisdom.

    Either I have a problem with the trigger signal to the coil from the ECU or perhaps an issues with the torque convertor/flexplate.

    Cylinder 1 and 6 share one side of the coil, and I'm assuming the same trigger wire. I haven't been able to find a wiring diagram.

    Love the truck. Not loving the experience currently and have nearly reached my wits end. Shopping for another daily driver as the Disco isn't dependable currently.

    Thanks in advance for any feedback!

  2. #2
    Join Date
    Oct 2011
    Location
    Mountains of Western Pennsy.
    Posts
    538

    Default

    Get a copy of the "RAVE" manual on line for free, it's a shop manual for several different Land Rovers. Which engine, 4.0 or 4.6? The 4.6's have a problem with the upper cylinder head bolts holes cracking (NOTE: in the block) and the symptoms are like a blown head gasket (Rover N.A. says this doesn't happen...Duh). The fix for this problem is industrial block sealer (CDC I think is the brand name). There's a cheap gadget (about $30) that checks for exhaust gasses in the cooling system, that may be of help. Also, if you changed head gaskets and didn't have the cylinder head straightened (flattened) it will take out the gasket again in short order. At long distance it's hard to tell exactly what's going on, but throwing parts at it is futile... Oh, and try over at "Discoweb" they may have some helpful hints, it's more active in this department.

    '99 Disco II
    '95 R.R.C. Lwb (Gone...)
    '76 Series III Hybrid 109
    '70 Rover 3500S (Gone...)
    Last edited by mearstrae; 08-15-2019 at 04:16 PM. Reason: More in formation

  3. #3
    Join Date
    Jun 2007
    Posts
    17

    Default

    Thanks for the reply. We got the heads straightened before doing the head gaskets. I'll check for exhaust gases and pull up the RAVE manual and see what I can find out.

    Thanks again! John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us