View Full Version : Still running rough...

B. Wallace
03-20-2007, 07:04 PM
I swore I was going to solve this on my own, but I've done everything I could possibly think of to fix the problem, but no luck.
First off, this was a problem I knew of before I bought it. I figured it would be an easy fix. It idles great. It runs great when it's cold. When the engine warms up, it still idles fine. The only thing I've noticed at idle is a "miss" in the exhaust, which when you put your hand over the exhaust pipe, is much hotter than the normal exhaust. This is every 10 seconds or so.

When driving after the engine is warm, it seems to bog down in every gear. And I'm not hot-rodding the truck either. But if I simply, barely ease my foot off the gas, it smoothes out. It will continue to acccelerate at this position, but if I try to give it any more gas, it bogs down again.
Other than this it runs great. Here is a list of everything I've replaced, and yes, the timing is correct.

New inline fuel filter
New spark plugs/wires
New fuel pump
New Weber carb
Pertronix igniter and coil/new coil wire
New tail pipe and muffler

I believe that's everything. Does this point to maybe an exhaust leak? Or is there something obvious I'm missing here. Any help would be greatly appreciated. I refuse to take it to anyone, but it may come down to that soon. (Hopefully not though)http://www.roversnorth.com/forums/images/icons/icon7.gif


03-20-2007, 07:18 PM
New carb? Is it jetted for a Land Rover and for your altitude? Have you checked for vacume leaks around the carb gasket or any uncapped fittings on the carb or intake manifold? Linkage set up properly? when was the last time you adjusted your valves?

Thats all i can think of right now.

B. Wallace
03-20-2007, 07:47 PM
It was doing this exact same thing the day I bought it. It was 100% original then too (Zenith carb). New Weber carb., same problem. It's like nothing changed at all. So, obviously the problem is not in anything that I've checked and replaced. I haven't found any vacuum leaks either. Any other suggestions?

LH Drive
03-20-2007, 11:33 PM
Sounds just likr the problem I had. Have you tried adjusting the air/fuel mixture on the carb? Screw it all the way down then back off 1 1/2-2 turns. I am also new to Series Rovers as this is my first. I had this same problem with mine when I bought it. It had been parked for over 2 years. We got the engine to run, It would idle a little rich but not stall. You could even drive it a few blocks then it would die after the engine got hot. The engine would not turn on at all till it cooled down. The exhaust would get very hot, you could light a cigarette off the pipes. I thought the muffler was shot. Guy I bought the Rover from said the gas tank had gunk in it and that was the problem for it not running well. Claims that the engine had been built by Turner Engineering in the UK and shipped to him to install for the PO 3 years before the rover was parked due to the death of the PO. The Widow left him the Series for him to sell as is two years later.
I ran a new line to a clean gas can and the same thing would happen.
After hours of breaking my head over this I decided to clean the fuel pump and found the diaphram was torn from the rusty gunk out of the fuel tank. I cleaned the distributer cap, replaced the plugs, cleaned the Zenith carb, and installed a new fuel pump. It ran better and would not stall anymore. I then adjusted the air mixture screw on the carb and got the engine to idle at lower rpms and that also quiet the engine down. Also the exhaust did not heat up anymore. I also set the timing with a tach and it made a difference.
I'm getting ready to place the Rover back on the road and have added a new Webber carb and hope to get better fuel milage...I hope

03-21-2007, 07:30 AM
We had similar issues with our 1971 IIA - tune it sitting there in the driveway, timing, mixture, idle, did it by the book for a Weber 341ch. Would run great. Push the gas hard and it would start running rough. The only way to get it to run right would be to feather the throttle slowly and it would idle correctly again. I did a lot of research, even talked to the Redline Weber folks - the jetting is critical, and out of the box it is not necessarily correct for your LR engine. I was unwilling and unqualified to start a rejetting process. I bought a new Zenith and put it on. It was better, but similar problems surfaced again, just not all at one time. Several things we found:
1 - plastic spacer at base of carb was hairline cracked = vacuum leak
2 - PCV rubber diaphragm had a hole in it - replaced it and it helped
3 - People who know how to tune a carb can do things we couldn't get done

A note came with the new Zenith: do not make adjustments more than 1/4 turn for idle and mixture at a time. The carb is set for the 2.25 LR petrol engine from the factory. That was born out when we put it on and it ran good. I have not been able to find instructions for adjusting the Zenith. It might be worth the money to have a qualified carb guy run through it. Might find something small like ours did to solve some of your issues.

03-21-2007, 09:57 AM
make sure your points are correctly adjusted.hows your rotor and dizzy cap.i would change them if you do have not done so.
look closely at the dizzy drive ,does it wobble or fill loose.could have a worn out dizzy.
look closely at the vaccum advance ,does it work? vaccum advance hose not torn or loose.
i would do a compression test.looking for a weak or low compression in a cylinder,i burnt valve may cause poor performance as well .
adjust the valves..good luck
www.singingcamel.com (http://www.singingcamel.com)

03-21-2007, 12:19 PM
My brother had a Rover that ran fine at first, then there was a problem that happened with increasing frequency. It would idle all day long, start fine but would lose all power soon after driving off. It was very maddening. He eventually tracked it down to the fuel pump that was covered in an amazing amount of gunk that seemed to be YEARS of the old car gunk mix of oil, dust, grime, dirt, bug parts and so on and so forth.

Basically the pump would pump a bit but was so gunked up that it wouldn't do the full pump because it couldn't go fully back to the 'start' position. It could be a factor of your problem. Good luck in figuring it out!


03-21-2007, 12:22 PM
Doh! Doh! Doh!

Ignore previous post - once again I forgot about part of the post that I was responding to! You do specifically mention 'New Fuel pump' in your post.

Well, just remember the bit about 'Good luck' figuring it out.


LH Drive
03-21-2007, 01:11 PM
Incase you are not getting enough fuel. Check the Fuel pickup pipe located on the gas tank. Easy access on a series rover since they have removable panels. I found that my fuel pickup pipe had a few rusted thru pinholes at the top of the pipe. I repaired it with a new brass 5/16 tubing from True Value Hardware($5), used a pencil die grinder on the brass neck to make room for the tubing to slide in the neck 1/4 inch. I then soldered it to the brass neck fitting. Looks New after cleaning all the grime off the fitting and better than paying $99 for a new one.