View Full Version : 1995 rover lwb problems

11-26-2006, 11:50 AM
having major problems. it started with a cracked exhaust just above the O2 sensor. replaced the y pipe and the O2 sensors. replaced the cold start sensor because I was having flooding problems. new wires, coil and plugs. thought the spark was weak. there was a fault code #34 but that is gone now. then there was a fualt code #02. thats gone. I cant drive it right now. anybody have any ideas?
other problems: rear windows dont work. there is power at both switches. also the power door locks dont work. my last rover (a 93 lwb-totalled) was so much better that this load.

Rod Turnbull
11-26-2006, 02:41 PM
Check this link out for a solution for the windows... you will find the control unit in the glove box between the seats, lift out the insert, it looks similar to the Disco one. You may find cleaning the contacts is all you need to get the windows working.



11-27-2006, 01:31 PM
search the archives for fuseable link problems and solutions.marc

11-17-2008, 04:13 PM
replaced the ignition module, coil, plug wires, cap, rotor..... still no spark. Plenty of fuel though. the display under the passenger seat doesnt show any codes ???? there is power to the ECU and the relays all seem in order. Any ideas?

11-17-2008, 05:41 PM
Try replacing the temperature sensor in the front of the valley, not next to the thermostat. The one near the thermostat is for the temp gauge, the other feeds the ECU.

Classic ECUs do often degrade. They are hard to find even in the UK, and finding one for a LSE will be harder. Do you know anyone with the same model? If so borrow his ECU and see if it works.

I have a Classic Vogue with a 4.6 fitted with 3.9 Stage 1 heads and Efi. It was having flooding problems until I replaced the sensor.

11-20-2008, 08:36 AM
I had a similar issue recently with my 95. Check out the thread on discoweb.org with the same user id as here... I replaced everything you did and needed to replace the inertia switch to finally resolve the issue.
To get it started now, you need two people to do the following:
unplug the intertia switch, have the other person crank the car with their foot flat on the accelerator pedal for about 20-30 seconds. When it is just about to start (you'll hear it), plug the switch back in again and it should start. Worked for me...all is well now. I replaced the switch just to be sure.