View Full Version : Key Fob Syncing...

08-11-2009, 07:41 PM
I just got my 2000 P38 back from the shop (they replaced the intake gasket). It appears that they disconnected the battery (as they should) to do the repair, because the clock was not telling the right time. (but the windows were re-synced) and now, my key fob wont lock or unlock the vehicle. I use the key, but I don't see the red 'armed' light on the dash activated either. When I use the fob, it's LED illuminates (the batteries are pretty new). I tried holding down the lock button and also the unlock button while I manually locked and unlocked the car, but still no joy. Does anyone have an idea what this might be, or what I am doing wrong?

08-16-2009, 02:27 PM
Interesting... not one reply (save a private message).

Well, here's what's new. I tried all of the 're-sync' procedures that I could find in the manual, in the owner's handbook and some 'other sources'. Not one of them worked. There was no visible response to any of those efforts and so I just gave up. I've been locking the car with the key now, for about a week, and the oddest thing happened today. I locked it with the key as usual when I went into a store. (Now it has to be mentioned here, that all of the time I was locking it with the key, it DID NOT arm the alarm system.) When I returned to the car, I unlocked the car, but only the driver's lock button on the door went up. I tried it again, with the same results. So I just said to myself, 'That's odd...' and opened the door. The alarm began going off and I shut the door and tried to lock and unlock it again with the key. Nothing... So then I thought, 'Well, what the heck...' and I pushed the unlock button on the fob. Immediately the alarm was disarmed and all of the locks began working simultaneously. The batteries are about a year old, but the fob light was always working the entire time that I've been trying to use it.

Is it possible that after a 7 day period or something, the system 'resets' on it's own? It's very peculiar... All I can figure is that after years of driving MGs and Triumphs, God looked down and said, 'Oh geeeeez! He's still driving silly British cars with their dumb-ass electrical systems?' took pity on me, and just fixed it for me. LOL

At any rate, it's verrrrrrrry strange. I think I should replace the batteries in the fob, but first I'm going to wait and see if it gets hinkey again, before I do. As they say, 'If it ain't broke, don't fix it.'

Just thought this update might be interesting to a few of you.


08-16-2009, 08:15 PM
If I were to guess, I would check for corrosion in the key fob or a bad solder joint.

08-18-2009, 07:46 AM
After re-attaching the battery you need to sync the key to the Range Rover. Put the fob in the door and turn it to Lock, push the lock button, release and center the key. Turn the key to Unlock and push the Unlock button. That should re-set the key fob. You said you were doing this?

IDoes anyone have an idea what this might be, or what I am doing wrong?

08-18-2009, 11:44 PM
Oh, I know about the procedure you mentioned. I tried it, and several others, but with no joy. I have had the fob apart and dont see any bad solder points, or corrosion. I replaced the battery cover, and the button cover. (last year) Now it works just like it did before it 'failed' two weeks ago. No glitches, no hitting it just right, it works like new.

It's like someone came and just fixed it while I was in the store that day. LOL However it happened, I'm grateful, but it wasn't from any of the procedures that I tried. (unsuccessfully) That's why I wondered if it was some sort of '7 day reset' or something, because I tried all kinds of 're-syncing' procedures and was worried that after doing too many, It might disable the system for a while or something.