Results 1 to 5 of 5

Thread: 1984 Santana 88 Gear or Clutch problem?? Novice needs help...

  1. #1

    Default 1984 Santana 88 Gear or Clutch problem?? Novice needs help...

    Hello All! New to the forum and happy to be here. I recently acquired a 1984 Santana 88, 2.25L diesel w/ overdrive. I have had it for about 3 months and have occasionally driven it here and there without an issue. Just today when about to take it for a little spin, when it started fine but I could not get it to engage any gear except Reverse...and once I got in Reverse, it got stuck in gear.

    I let it sit for a bit after turning off the engine. After about 30 mins, I started it again and was able to disengage Reverse (whew!). It will engage gears when the engine is OFF but once I turn on the engine, no gears will engage. The clutch pedal feels a little "loose", but that could be my imagination....thoughts?

    About me: fairly novice when it comes to self repairs and maintenance, but one of the reasons I bought this vehicle was to try and get more into working on my own car.

    Thank you in advance for any advice or help...

  2. #2

    Default

    Its possible that the clutch is not disengaging properly so the engine is still trying to drive the gearbox thus baulking the shift into gear. Check the fluid level in the clutch system for a starter and check for any leaks either at the pedal or the cylinder on the clutch housing.

  3. #3

    Default

    Deleted , duplicatd

  4. #4
    Join Date
    Dec 2010
    Posts
    148

    Default

    yea, the first assumption is air in the clutch but i've had two xmissions (the last on a dozer!) lock up for other reasons.......... make sure you have a working clutch slave and master cylinder with the AIR OUT OF IT.
    after that it gets complicated but it's prob air in the clutch.

  5. #5

    Default

    I have a 1987 Land Rover Santana series iiiA. I had the same issue, but my fluid was leaking. It turns out I had a bad master clutch cylinder. I purchased a standard Land Rover part and the problem was resolved. The only other problem I encountered was a seized vacuum pump for the power assisted brakes. I actually replaced it with an electric pump which has been working fine for almost two years. My LR has a 2.25L diesel.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us