I just bought a new half-shaft because mine was all mangled/scratched around the shaft housing that fits inside the hub. It's an aftermarket... Bearmach brand.. says "made in India"... and not purchased from our hosts.

I got the package today after a 1.5 week wait shipping from the UK. I opened up the package and I looked at the part and noticed it's really poorly machined. The casting looks okay, but the bore hole for the universal joint is off-center. One of the side-walls is 0.155" thick and the other side is 0.219". It's enough to be visibly unbalanced, and worryingly thin on the thin side . I mean, it's like an 1/8" of metal holding my entire drive train together on that side. This has me worried.

Should I install this on my car, or send it back for another one?
It might not be an issue, but it's a rotating assembly...and that much "visible" offset tells me it's going to wobble at higher speeds. But then again, it's nearly at the wheel, so the RPM isn't going to be that high. But then again, a couple grams difference in tire wear and they put weights on the rim to balance that. A little bit matters, right? So, this much metal shifted over ( I'm thinking of the U joint also sitting offset because of this ) would definitely cause some wobble. How could no one notice this at Baermach?! The quality control is terrible! I'm throwing John Craddock under the bus here, too...as they supplied it. But it was cheap, I share the blame for picking it.

I've been waiting 3 weeks with my Landy on jack stands in front of my house because of this. I hate to wait another 2 weeks. But, I'd have more money into just the non-reusable supporting parts (genuine bearing races, retainer clips, gear oil) than this part costs. I think I only paid $25-$30 new for it, and the bearing races that is press-fit on it costs $60(genuine LR). So, I hate to put it on and have to remove it, 3 weeks later and have to re-order new bearing races, etc.

I just hate to lose all this time more than anything.

Any advice from the community? Check out these pics...

Click image for larger version. 

Name:	HalfShaft_OffCenterMachineBore.jpg 
Views:	101 
Size:	62.8 KB 
ID:	13678

For reference, here is what my current Half-Shaft looks like:
Click image for larger version. 

Name:	HalfShaft_old.jpg 
Views:	101 
Size:	90.0 KB 
ID:	13679

Notice the crazy gouges on the shaft. I don't think anything sits on there...but it's been rubbing on the hub assembly, clearly. The front differential was also bone-dry, and the bolts were all loose (vibration loosening, I think). I am replacing everything, by the way...swivel balls, seals, bolts, hub, wheel bearings, u-joint, etc. It will all be sitting in some nice new grease and gear oil, with fresh seals...but this stupid new part has be re-thinking if I should order a new replacement...or re-use the old one...or just put this offset one in there???