Results 1 to 3 of 3

Thread: Directional signal won't blink on one side

  1. #1
    Join Date
    Apr 2010
    Posts
    99

    Default Directional signal won't blink on one side

    The directional signal/turn signal on the left side of my IIA won't flash/blink. The right side works normally and, when I turn the hazard lights, on all four blink normally. I replaced the flasher unit about a year ago. Any ideas what could be the problem?
    1970 Series IIA
    1964 Series IIA [sold]

  2. #2

    Default

    Check your grounds.
    I had a similar issue after removing the front wings, cleaning, painting, and reassembling.
    After chasing things down with a volt/ohm meter, I finally ran a ground wire from the wing to the chassis and it fixed the lack of blinker problem.

  3. #3

    Default

    Had the same issue, removed the directional lens, noted that one screw holding the assembly had a copper piece that was corroded. Removed screw and used dremel to clean the copper piece, reassembled and worked great. Just my 2 cents. Best, phil
    2003 Corvette Z06
    2013 Range Rover Sport
    1967 Series IIA - For when I don't want to go fast.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Unparalleled product knowledge. Our mission is to support all original Land Rover models no longer supported by your local Land Rover franchise. We offer the entire range of Land Rover Genuine Parts direct from Land Rover UK, as well as publish North America's largest Land Rover publication, Rovers Magazine.
Join us